Browse Source

Add ruby 2.2 detection

Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
pull/1/head
Slávek Banko 7 years ago
parent
commit
26e29db0fc
  1. 6
      amarok/configure.in.in

6
amarok/configure.in.in

@ -1137,6 +1137,12 @@ if test -n "$PKG_CONFIG"; then
RUBY_CFLAGS=`$PKG_CONFIG ruby-2.1 --cflags`
fi
fi
if test -z "$RUBY_VERSION"; then
RUBY_VERSION=`$PKG_CONFIG ruby-2.2 --modversion 2>/dev/null`
if test -n "$RUBY_VERSION"; then
RUBY_CFLAGS=`$PKG_CONFIG ruby-2.2 --cflags`
fi
fi
if test -z "$RUBY_VERSION"; then
# pkgconfig file does not exist but might be 1.9.1: RUBY_VERSION defined in ruby/version.h
if test -n "$RUBY -r rbconfig -e 'printf("%s",RbConfig::CONFIG@<:@"rubyhdrdir"@:>@)'"; then

Loading…
Cancel
Save