diff --git a/dev-tqt/tqtinterface/metadata.xml b/dev-tqt/tqtinterface/metadata.xml
index 1fb59563..6e9f5e4a 100644
--- a/dev-tqt/tqtinterface/metadata.xml
+++ b/dev-tqt/tqtinterface/metadata.xml
@@ -5,8 +5,4 @@
fatzer2@gmail.com
Alexander Golubev
-
diff --git a/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild b/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild
index a5599705..e3b77b42 100644
--- a/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild
+++ b/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild
@@ -3,17 +3,17 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+
TRINITY_MODULE_TYPE="dependencies"
TRINITY_MODULE_NAME="tqtinterface"
-
inherit trinity-base-2
DESCRIPTION="Interface and abstraction library for TQt and Trinity"
HOMEPAGE="https://trinitydesktop.org/"
LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
DEPEND="~dev-tqt/tqt-${PV}
virtual/glu"
@@ -24,10 +24,10 @@ pkg_setup() {
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DUSE_QT3=ON
-DQT_PREFIX_DIR="${QTDIR}"
)
- cmake-utils_src_configure
+ cmake-utils_src_configure
}
diff --git a/dev-tqt/tqtinterface/tqtinterface-14.0.7.ebuild b/dev-tqt/tqtinterface/tqtinterface-14.0.7.ebuild
index a5599705..e3b77b42 100644
--- a/dev-tqt/tqtinterface/tqtinterface-14.0.7.ebuild
+++ b/dev-tqt/tqtinterface/tqtinterface-14.0.7.ebuild
@@ -3,17 +3,17 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+
TRINITY_MODULE_TYPE="dependencies"
TRINITY_MODULE_NAME="tqtinterface"
-
inherit trinity-base-2
DESCRIPTION="Interface and abstraction library for TQt and Trinity"
HOMEPAGE="https://trinitydesktop.org/"
LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~amd64 ~x86"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
DEPEND="~dev-tqt/tqt-${PV}
virtual/glu"
@@ -24,10 +24,10 @@ pkg_setup() {
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DUSE_QT3=ON
-DQT_PREFIX_DIR="${QTDIR}"
)
- cmake-utils_src_configure
+ cmake-utils_src_configure
}
diff --git a/dev-tqt/tqtinterface/tqtinterface-9999.ebuild b/dev-tqt/tqtinterface/tqtinterface-9999.ebuild
index 76d0ba48..c9479c37 100644
--- a/dev-tqt/tqtinterface/tqtinterface-9999.ebuild
+++ b/dev-tqt/tqtinterface/tqtinterface-9999.ebuild
@@ -3,16 +3,16 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
+
TRINITY_MODULE_TYPE="dependencies"
TRINITY_MODULE_NAME="tqtinterface"
-
inherit trinity-base-2
DESCRIPTION="Interface and abstraction library for TQt and Trinity"
HOMEPAGE="https://trinitydesktop.org/"
+
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
-
IUSE="+opengl"
DEPEND="~dev-tqt/tqt-${PV}[opengl=]
@@ -24,9 +24,9 @@ pkg_setup() {
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DQT_PREFIX_DIR="${TQTDIR}"
)
- cmake-utils_src_configure
+ cmake-utils_src_configure
}