You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

137 lines
4.4 KiB

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

#!/bin/sh
# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
# Copyright 2009, 2010, 2011, 2012, 2013, 2014, 2015 Eric Hameleers, Eindhoven, Netherlands
# Copyright 2015-2017 Thorn Inurcide
# Copyright 2015-2017 tde-slackbuilds project on GitHub
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for
# any purpose with or without fee is hereby granted, provided that
# the above copyright notice and this permission notice appear in all
# copies.
#
# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
# IN NO EVENT SHALL THE AUTHORS AND COPYRIGHT HOLDERS AND THEIR
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
# USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
# OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT
# OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
# SUCH DAMAGE.
PRGNAM=digikam
VERSION=${VERSION:-$TDEVERSION}
BUILD=${BUILD:-1}
TAG=${TAG:-_tde}
source ../../get-source.sh
getsource_fn
untar_fn
[[ $TDEVERSION == R14.0.4 ]] && {
## fix for gcc7:
##In file included from ../../../../../digikam/imageplugins/coreplugin/sharpnesseditor/matrix.cpp:35:0:
##/usr/include/stdlib.h:751:12: error: expected unqualified-id before int
## extern int abs (int __x) __THROW __attribute__ ((__const__)) __wur;
## ^
echo '--- digikam/imageplugins/coreplugin/sharpnesseditor/clapack/f2c.h
+++ digikam/imageplugins/coreplugin/sharpnesseditor/clapack/f2c.h
@@ -157 +156,0 @@
-#define abs(x) ((x) >= 0 ? (x) : -(x))
--- digikam/imageplugins/coreplugin/sharpnesseditor/matrix.cpp
+++ digikam/imageplugins/coreplugin/sharpnesseditor/matrix.cpp
@@ -32,0 +33,5 @@
+// C++ includes.
+#include <stdlib.h>
+#include <cmath>
+using ::abs;
+
@@ -38,4 +42,0 @@
-
-// C++ includes.
-
-#include <cmath>' | while read line
do
patch -p0
done
}
listdocs_fn
# set support for additional language(s) as per I18N variable
# but only for languages available with this package
langs="";for Lang in $I18N;do [[ -d po/$Lang ]] && langs="$langs $Lang";done
sed -i "s|SUBDIRS =.*$|SUBDIRS =.$langs|" po/Makefile.am
# only package help documents where they exist for the languages being included
langdocdk="digikam";for Lang in $langs;do [[ -d doc/$Lang"_digikam" ]] && langdocdk=$(echo $Lang"_digikam" $langdocdk);done
langdocsf="showfoto";for Lang in $langs;do [[ -d doc/$Lang"_showfoto" ]] && langdocsf=$(echo $Lang"_showfoto" $langdocsf);done
sed -i "s|SUBDIRS =.*$|SUBDIRS =. $langdocdk $langdocsf|" doc/Makefile.am
ltoolupdate_fn
chown_fn
cd_builddir_fn
LDFLAGS="${SLKLDFLAGS}" \
CFLAGS="${SLKCFLAGS} $TQT_INCLUDE_PATH" \
CXXFLAGS="${SLKCFLAGS}" \
CC=${COMPILER} \
CXX=${COMPILER_CXX} \
../configure \
--prefix=${INSTALL_TDE} \
--sysconfdir=$SYS_CNF_DIR \
--mandir=${INSTALL_TDE}/man \
--disable-rpath \
--enable-closure
make_fn
installdocs_fn
strip_fn
mkdir_install_fn
echo "
# HOW TO EDIT THIS FILE:
# The 'handy ruler' below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|' on
# the right side marks the last column you can put a character in. You must make
# exactly 11 lines for the formatting to be correct. It's also customary to
# leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
digikam: Digikam is a digital photo management application for the TDE desktop.
digikam:
digikam: Showfoto is a photo viewer and editor.
digikam:
digikam: With language support for:
digikam:
digikam: en $(echo $langs)
digikam:
digikam:
digikam:
digikam:
" > $PKG/install/slack-desc
# If building with additional language support, showfoto doesn't run using the language selected
# because showfoto.mo files are not being built. This is added into the build at this packaging
# stage as a work-around to provide the translations for showfoto ..
if [ -d $PKG${INSTALL_TDE}/share/locale ]
then
for DIR in $PKG${INSTALL_TDE}/share/locale/*/LC_MESSAGES/
do
(cd $DIR
ln -s digikam.mo showfoto.mo)
done
fi
makepkg_fn