You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

40 lines
1.6 KiB

#!/usr/bin/make -f
DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
&& echo xz || echo bzip2)
O_LD_PATH := $(LD_LIBRARY_PATH)
export LD_LIBRARY_PATH = $(O_LD_PATH):/opt/trinity/lib
DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)
DH_PYTHON2 = $(if $(wildcard /usr/bin/dh_python2),dh_python2,dh_pysupport)
DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/opt/trinity --with-extra-libs=/opt/trinity/lib --with-extra-includes=/opt/trinity/include
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/autotools.mk
DEB_CONFIGURE_INCLUDEDIR := /opt/trinity/include
DEB_CONFIGURE_MANDIR := /opt/trinity/share/man
DEB_CONFIGURE_PREFIX := /opt/trinity
DEB_CONFIGURE_INFODIR := /opt/trinity/share/info
cdbs_configure_flags := --with-qt-dir=/usr/share/qt3 --disable-rpath --with-xinerama $(cdbs_kde_enable_final) $(cdbs_kde_enable_debug)
makebuilddir:: debian/stamp-autoreconf
debian/stamp-autoreconf:
dh_testdir
autoreconf -vi
touch debian/stamp-autoreconf
install/python-compizconfig-trinity::
# mkdir -p debian/python-compizconfig-trinity/opt/trinity/lib/
# cp -Rp debian/python-compizconfig-trinity/usr/lib/* debian/python-compizconfig-trinity/opt/trinity/lib/
# rm -rf debian/python-compizconfig-trinity/usr/lib/
# Why are static and libtool libraries even built?
rm debian/python-compizconfig-trinity/opt/trinity/lib/python*/site-packages/*.a
rm debian/python-compizconfig-trinity/opt/trinity/lib/python*/site-packages/*.la
binary-install/python-compizconfig-trinity::
${DH_PYTHON2}