Removing unused patches

Signed-off-by: ormorph <roma251078@mail.ru>
(cherry picked from commit 187e714ba6)
r14.1.x
ormorph 6 months ago committed by Slávek Banko
parent 62039a8c3d
commit 2cc7a093ac
No known key found for this signature in database
GPG Key ID: 608F5293A04BE668

@ -1,32 +0,0 @@
--- starttde 2019-01-27 13:01:05.443907841 +0300
+++ starttde.gentoo 2019-01-27 13:01:48.203621371 +0300
@@ -178,7 +178,7 @@
# Modify the following environment variables only as necessary.
- if ! is_in_path PATH "$TDEDIR/games" ; then
+# if ! is_in_path PATH "$TDEDIR/games" ; then
# Respect the traditional path order. Don't blindly place $TDEDIR/games
# first in the path. Only place $TDEDIR/games before /usr/games. If packagers
# are adding $TDEDIR/games elsewhere, then they need to ensure the traditional
@@ -190,9 +190,9 @@
else
export PATH=$TDEDIR/games:$PATH
fi
- fi
+# fi
- if ! is_in_path PATH "$TDEDIR/bin" ]; then
+# if ! is_in_path PATH "$TDEDIR/bin" ]; then
# Respect the traditional path order. Don't blindly place $TDEDIR/bin
# first in the path. Only place $TDEDIR/bin before /usr/bin. This order is
# consistent with tdelibs/tdesu/stub.cpp. If packagers are adding $TDEDIR/bin
@@ -204,7 +204,7 @@
else
export PATH=$TDEDIR/bin:$PATH
fi
- fi
+# fi
if [ -x /usr/bin/manpath ]; then
if [ "`manpath 2>/dev/null | grep \"$TDEDIR/share/man\"`" = "" ]; then

@ -1,12 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -374,6 +374,9 @@
find_package( Backtrace )
if ( Backtrace_FOUND )
set ( HAVE_BACKTRACE 1 )
+ else ()
+ set ( Backtrace_LIBRARY "" )
+ set ( Backtrace_HEADER "" )
endif ()
endif ()
check_cxx_source_compiles( "#include <cxxabi.h>

@ -1,20 +0,0 @@
--- a/tdecore/tdehw/tdehardwaredevices.cpp
+++ b/tdecore/tdehw/tdehardwaredevices.cpp
@@ -2906,7 +2906,7 @@
ndevice->internalSetIpV6Netmask(address);
}
}
- s = getnameinfo(ifa->ifa_ifu.ifu_broadaddr, (family == AF_INET) ? sizeof(struct sockaddr_in) : sizeof(struct sockaddr_in6), host, NI_MAXHOST, NULL, 0, NI_NUMERICHOST);
+ s = ifa->ifa_ifu.ifu_broadaddr ? getnameinfo(ifa->ifa_ifu.ifu_broadaddr, (family == AF_INET) ? sizeof(struct sockaddr_in) : sizeof(struct sockaddr_in6), host, NI_MAXHOST, NULL, 0, NI_NUMERICHOST) : EAI_NONAME;
if (s == 0) {
TQString address(host);
if (family == AF_INET) {
@@ -2917,7 +2917,7 @@
ndevice->internalSetIpV6Broadcast(address);
}
}
- s = getnameinfo(ifa->ifa_ifu.ifu_dstaddr, (family == AF_INET) ? sizeof(struct sockaddr_in) : sizeof(struct sockaddr_in6), host, NI_MAXHOST, NULL, 0, NI_NUMERICHOST);
+ s = ifa->ifa_ifu.ifu_dstaddr ? getnameinfo(ifa->ifa_ifu.ifu_dstaddr, (family == AF_INET) ? sizeof(struct sockaddr_in) : sizeof(struct sockaddr_in6), host, NI_MAXHOST, NULL, 0, NI_NUMERICHOST) : EAI_NONAME;
if (s == 0) {
TQString address(host);
if (family == AF_INET) {

@ -1,11 +0,0 @@
--- a/tdecore/malloc/malloc.c
+++ b/tdecore/malloc/malloc.c
@@ -4306,7 +4306,7 @@
remainder_size = chunksize(p);
if (opts & 0x2) { /* optionally clear the elements */
- memset(mem, 0, remainder_size - SIZE_SZ - array_size)
+ memset(mem, 0, remainder_size - SIZE_SZ - array_size);
}
/* If not provided, allocate the pointer array as final part of chunk */
Loading…
Cancel
Save