Added libexecinfo package and fixes for tdelibs, fix #277

Signed-off-by: ormorph <roma251078@mail.ru>
pull/278/head
ormorph 1 year ago
parent e85983bae9
commit b1f87280c2

@ -0,0 +1 @@
DIST libexecinfo-1.1-3.tar.gz 5392 BLAKE2B 9eaf4f7f418bf5d53b6983775c743f52b46a70054b6bc7ba4281e5c053839fe8d85e016dc064c7af9246bf1dea95436baaf418f292bd7fdec227db37fefddc74 SHA512 a5015b0d3c6411deff16124599b3103431c396a07d630c19eb2887b40590a520d4e9dd5cd05f433b0aa2feaeeffea0432f4a0d45fd82f4939b077c79297256af

@ -0,0 +1,32 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MY_PV="${PV}-3"
DESCRIPTION="A quick-n-dirty BSD licensed clone of the GNU libc backtrace facility"
HOMEPAGE="https://www.freshports.org/devel/libexecinfo"
SRC_URI="https://github.com/mikroskeem/${PN}/archive/refs/tags/${PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="static-libs"
src_prepare() {
default
sed -i -e 's/CC=/CC?=/' \
-e 's/AR=/AR?=/' \
Makefile || die
}
src_install() {
einstalldocs
doheader execinfo.h
doheader stacktraverse.h
use static-libs && dolib.a libexecinfo.a
dolib.so libexecinfo.so.1
dosym ./libexecinfo.so.1 /usr/"$(get_libdir)"/libexecinfo.so
}

@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>team-gentoo@trinitydesktop.org</email>
<name>Trinity Gentoo ebuilds project</name>
</maintainer>
</pkgmetadata>

@ -0,0 +1,12 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -374,6 +374,9 @@
find_package( Backtrace )
if ( Backtrace_FOUND )
set ( HAVE_BACKTRACE 1 )
+ else ()
+ set ( Backtrace_LIBRARY "" )
+ set ( Backtrace_HEADER "" )
endif ()
endif ()
check_cxx_source_compiles( "#include <cxxabi.h>

@ -77,6 +77,10 @@ RDEPEND="${DEPEND}
)
"
PATCHES=(
"${FILESDIR}/tdelibs-backtrace.patch"
)
src_configure() {
local enable_logind="OFF"
if use systemd || use elogind; then

Loading…
Cancel
Save