media-libs/lcms: Remove unbuildable package due to py27 dependency

Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
pull/198/head
Andreas Sturmlechner 3 years ago committed by TDE Gitea
parent 1bfa5eac86
commit f2962b93fe

@ -1 +0,0 @@
DIST lcms-1.19.tar.gz 927752 BLAKE2B b8850f47652270082e11729119c35dfb90e112a40a80c531298b9585d89b3fba6e3ff1e0abd284ec2c6654a64fd44870f79d0a437917b8414e94d38afb66be93 SHA512 85a55ad0673f0df2aaa80d18caa50314319f8da5ee4d84eed919059d0dad9861d684ef6353ce0ec6f9892a4603ce8e8e12f84d46858e23f52846b8aefd3cf449

@ -1,20 +0,0 @@
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -22,7 +22,7 @@
endif
-_lcms_la_LDFLAGS = -no-undefined -module -avoid-version \
+_lcms_la_LDFLAGS = -no-undefined -module -avoid-version -shared \
-L$(LCMS_PYLIB)/config
_lcms_la_LIBADD = $(top_builddir)/src/liblcms.la -lpython$(PYTHON_VERSION)
@@ -31,7 +31,7 @@
_lcms_la_CPPFLAGS = -I$(PYTHON_PREFIX)/include/python$(PYTHON_VERSION) \
-I$(LCMS_PYINCLUDE) \
- $(AM_CPPFLAGS)
+ $(AM_CPPFLAGS) -shared
EXTRA_DIST = lcms.py lcms.i testbed swig_lcms

@ -1,49 +0,0 @@
cmsio1.c: In function 'AdjustEndianessArray16':
cmsio1.c:118: warning: implicit declaration of function 'swab'
testcms.c: In function 'CheckSwab':
testcms.c:113: warning: implicit declaration of function 'swab'
================================================================================
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,6 +6,9 @@
# Don't require all the GNU mandated files
AUTOMAKE_OPTIONS = 1.7 foreign
+# _XOPEN_SOURCE is required for swab() but undefines strcasecmp(), so add _GNU_SOURCE as well:
+AM_CPPFLAGS = -D_XOPEN_SOURCE -D_GNU_SOURCE
+
includedir = ${prefix}/include
# Shared libraries built in this directory
--- a/src/cmsio1.c
+++ b/src/cmsio1.c
@@ -24,6 +24,7 @@
#include "lcms.h"
+#include <unistd.h>
// ----------------------------------------------------------------- Tag Serialization
--- a/testbed/Makefile.am
+++ b/testbed/Makefile.am
@@ -6,6 +6,9 @@
# Don't require all the GNU mandated files
AUTOMAKE_OPTIONS = 1.7 foreign
+# Required for swab()
+AM_CPPFLAGS = -D_XOPEN_SOURCE
+
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include
check_PROGRAMS = testcms
--- a/testbed/testcms.c
+++ b/testbed/testcms.c
@@ -36,6 +36,7 @@
#include <time.h>
#include <stdio.h>
#include <stdlib.h>
+#include <unistd.h>
#ifndef NON_WINDOWS
#include <icm.h>

@ -1,107 +0,0 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 2020 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python2_7 )
inherit autotools eutils python-r1
DESCRIPTION="Lightweight, speed optimized color management engine"
HOMEPAGE="https://www.littlecms.com/"
SRC_URI="mirror://sourceforge/lcms/${PV}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="jpeg python static-libs tiff zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
# Don't use Gentoo mirrors
RESTRICT="mirror"
RDEPEND="
jpeg? ( virtual/jpeg:0 )
python? ( ${PYTHON_DEPS} )
tiff? ( media-libs/tiff:0 )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
python? ( >=dev-lang/swig-1.3.31 )"
PATCHES=(
"${FILESDIR}/${P}-disable_static_modules.patch"
"${FILESDIR}/${P}-implicit.patch"
)
src_prepare() {
# Python bindings are built/installed manually.
sed -e "/SUBDIRS =/s/ python//" -i Makefile.am || die
default
eautoreconf
# run swig to regenerate lcms_wrap.cxx and lcms.py (bug #148728)
if use python; then
cd python || die
./swig_lcms || die "swig failed to regenerate files"
fi
}
src_configure() {
econf \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--bindir="${EPREFIX}"/usr/bin \
--disable-dependency-tracking \
$(use_enable static-libs static) \
$(use_with jpeg) \
$(use_with python) \
$(use_with tiff) \
$(use_with zlib)
}
src_compile() {
default
if use python; then
local BUILD_DIR
BUILD_DIR=python
python_copy_sources
building() {
emake \
LCMS_PYEXECDIR="${EPREFIX}$(python_get_sitedir)" \
LCMS_PYINCLUDE="${EPREFIX}$(python_get_includedir)"
# No corresponding functions in python-r1
# LCMS_PYLIB="${EPREFIX}$(python_get_libdir)" \
# PYTHON_VERSION="$(python_get_version)"
}
python_foreach_impl run_in_build_dir building
fi
}
src_install() {
DOCS=(AUTHORS README* INSTALL NEWS doc/*)
default
if use python; then
local BUILD_DIR
BUILD_DIR=python
installation() {
emake \
DESTDIR="${D}" \
LCMS_PYEXECDIR="${EPREFIX}$(python_get_sitedir)" \
install
}
python_foreach_impl run_in_build_dir installation
fi
insinto /usr/share/lcms/profiles
doins testbed/*.icm
find "${ED}" -name '*.la' -delete || die
}

@ -1,16 +0,0 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>fatzer2@gmail.com</email>
<name>Alexander Golubev</name>
<description>The maintainer of the package in the overlay</description>
</maintainer>
<maintainer type="project">
<email>printing@gentoo.org</email>
<name>Gentoo Printing Project</name>
</maintainer>
<upstream>
<remote-id type="sourceforge">lcms</remote-id>
</upstream>
</pkgmetadata>
Loading…
Cancel
Save