You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
tde-packaging-gentoo/trinity-apps/kbibtex/kbibtex-14.1.2.ebuild

39 lines
736 B

# Copyright 1999-2024 Gentoo Authors
# Copyright 2020-2024 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
TRINITY_EXTRAGEAR_PACKAGING="yes"
TRINITY_HANDBOOK="optional"
TRINITY_LANGS="de fr it pl ru"
TRINITY_MODULE_TYPE="applications/office"
inherit trinity-base-2
DESCRIPTION="Bibliography editor for TDE"
HOMEPAGE="https://trinitydesktop.org/"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="14"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~arm64 ~x86"
fi
DEPEND="
dev-libs/libxslt
dev-libs/yaz
virtual/tex-base"
RDEPEND="${DEPEND}
dev-tex/bibtex2html
dev-tex/latex2rtf
"
src_configure() {
local mycmakeargs=(
-DBUILD_TRANSLATIONS=ON
)
trinity-base-2_src_configure
}