You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
tde-packaging-gentoo/trinity-apps/kscope/kscope-14.1.1.ebuild

42 lines
766 B

# Copyright 1999-2023 Gentoo Authors
# Copyright 2020-2023 The Trinity Desktop Project
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
TRINITY_EXTRAGEAR_PACKAGING="yes"
TRINITY_HANDBOOK="optional"
TRINITY_LANGS="de zh_CN"
TRINITY_MODULE_TYPE="applications/development"
inherit trinity-base-2
DESCRIPTION="TDE front-end to Cscope"
HOMEPAGE="https://trinitydesktop.org/"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="14"
if [[ ${PV} != *9999* ]] ; then
KEYWORDS="~amd64 ~arm64 ~x86"
fi
RDEPEND="
media-gfx/graphviz
dev-util/cscope
dev-util/ctags
~trinity-base/kate-${PV}
"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/bison
sys-devel/flex
"
src_configure() {
local mycmakeargs=(
-DBUILD_TRANSLATIONS=ON
)
trinity-base-2_src_configure
}