You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
53 lines
1.6 KiB
53 lines
1.6 KiB
From 7218becac7132c2508d4e8f42c693d69c406795a Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
|
|
Date: Wed, 7 Mar 2018 15:14:22 +0100
|
|
Subject: [PATCH] Make pinentry-qt icon work under Plasma Wayland.
|
|
|
|
---
|
|
qt/Makefile.am | 2 ++
|
|
qt/main.cpp | 2 ++
|
|
qt/org.gnupg.pinentry-qt.desktop | 5 +++++
|
|
3 files changed, 9 insertions(+)
|
|
create mode 100644 qt/org.gnupg.pinentry-qt.desktop
|
|
|
|
diff --git a/qt/Makefile.am b/qt/Makefile.am
|
|
index 698005e..bbf39d1 100644
|
|
--- a/qt/Makefile.am
|
|
+++ b/qt/Makefile.am
|
|
@@ -24,6 +24,8 @@ bin_PROGRAMS = pinentry-qt
|
|
|
|
EXTRA_DIST = document-encrypt.png pinentry.qrc
|
|
|
|
+desktopdir = $(datadir)/applications
|
|
+dist_desktop_DATA = org.gnupg.pinentry-qt.desktop
|
|
|
|
if FALLBACK_CURSES
|
|
ncurses_include = $(NCURSES_INCLUDE)
|
|
diff --git a/qt/main.cpp b/qt/main.cpp
|
|
index fe88d26..b767cb4 100644
|
|
--- a/qt/main.cpp
|
|
+++ b/qt/main.cpp
|
|
@@ -372,6 +372,8 @@ main(int argc, char *argv[])
|
|
i = argc;
|
|
app = new QApplication(i, new_argv);
|
|
app->setWindowIcon(QIcon(QLatin1String(":/document-encrypt.png")));
|
|
+ app->setOrganizationDomain(QStringLiteral("gnupg.org"));
|
|
+ app->setDesktopFileName(QStringLiteral("org.gnupg.pinentry-qt"));
|
|
}
|
|
|
|
pinentry_parse_opts(argc, argv);
|
|
diff --git a/qt/org.gnupg.pinentry-qt.desktop b/qt/org.gnupg.pinentry-qt.desktop
|
|
new file mode 100644
|
|
index 0000000..0ac89aa
|
|
--- /dev/null
|
|
+++ b/qt/org.gnupg.pinentry-qt.desktop
|
|
@@ -0,0 +1,5 @@
|
|
+[Desktop Entry]
|
|
+Type=Application
|
|
+Name=Pinentry dialog
|
|
+Icon=document-encrypt
|
|
+NoDisplay=true
|
|
--
|
|
2.16.1
|
|
|