Browse Source

RPM: add support for opensuse Leap 15.3

Signed-off-by: François Andriot <albator78@libertysurf.fr>
pull/95/head
François Andriot 3 months ago
parent
commit
5a9c30ef24
  1. 10
      redhat/Makefile
  2. 28
      redhat/docker/oss153/Dockerfile.x86_64
  3. 202
      redhat/docker/oss153/packages
  4. 4
      redhat/docker/oss153/rpmmacros
  5. 20
      redhat/main/tdebase/tdebase.spec
  6. 2
      redhat/main/tdelibs/tdelibs.spec

10
redhat/Makefile

@ -134,12 +134,12 @@ tdewebdev: tdebase tdesdk
### 3rd party libraries and tools
brp-check-trinity:
ifneq (,$(filter $(DIST), .oss151 .oss152 .osstw ))
ifneq (,$(filter $(DIST), .oss151 .oss152 .oss153 .osstw ))
$(call buildpkg,3rdparty/brp-check-trinity)
endif
esound:
ifneq (,$(filter $(DIST), .el8 .mga6 .mga7 .mga8 .oss151 .oss152 .osstw ))
ifneq (,$(filter $(DIST), .el8 .mga6 .mga7 .mga8 .oss151 .oss152 .oss153 .osstw ))
$(call buildpkg,3rdparty/esound)
endif
@ -154,7 +154,7 @@ ifneq (,$(filter $(DIST), .mga6 .mga7 .oss151 .osstw ))
endif
lcms:
ifneq (,$(filter $(DIST), .el7 .el8 .mga7 .mga8 .oss151 .oss152 .osstw ))
ifneq (,$(filter $(DIST), .el7 .el8 .mga7 .mga8 .oss151 .oss152 .oss153 .osstw ))
$(call buildpkg,3rdparty/lcms)
endif
@ -162,7 +162,7 @@ libbeagle:
$(call buildpkg,3rdparty/libbeagle)
mp4v2:
ifneq (,$(filter $(DIST), .oss151 .oss152 .osstw ))
ifneq (,$(filter $(DIST), .oss151 .oss152 .oss153 .osstw ))
$(call buildpkg,3rdparty/mp4v2)
endif
@ -503,7 +503,7 @@ qalculate-tde:
$(call buildpkg,applications/qalculate-tde)
qt4-tqt-theme-engine: tdebase
ifeq (,$(filter $(DIST),.el5 .el6 .el8 .osstw))
ifeq (,$(filter $(DIST),.el5 .el6 .el8 .oss153 .osstw))
$(call buildpkg,applications/qt4-tqt-theme-engine)
endif

28
redhat/docker/oss153/Dockerfile.x86_64

@ -0,0 +1,28 @@
FROM opensuse/leap:15.3
ARG TDE_VERSION=14.0.10
ARG ARCH=x86_64
# Add PACKMAN repository
# Install Trinity build dependencies
COPY packages /packages
RUN echo PROXY_ENABLED="YES" >>/etc/sysconfig/proxy \
&& echo HTTP_PROXY="http://proxy:3128/" >>/etc/sysconfig/proxy \
&& zypper ar -f -G -n packman http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/ packman \
&& zypper refresh \
&& zypper -n install libudisks2-0-devel-2.8.1-1.39.x86_64.rpm https://ftp.lysator.liu.se/pub/opensuse/distribution/leap/15.3/repo/oss/x86_64/libudisks2-0-devel-2.8.1-1.39.x86_64.rpm \
&& zypper -n update \
&& zypper -n install -l $(</packages)
# Add non-root user to build packages
RUN useradd -m -s /bin/bash -u 1000 trinity \
&& echo "trinity ALL=(ALL) NOPASSWD: ALL" >>/etc/sudoers
USER trinity
COPY rpmmacros /home/trinity/.rpmmacros
# Add YUM repository for locally built packages
RUN mkdir -p /home/trinity/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} \
&& sudo zypper ar -C -G /home/trinity/rpmbuild/RPMS.tde-${TDE_VERSION}/${ARCH} rpmbuild.${ARCH} \
&& mkdir -p /home/trinity/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch \
&& sudo zypper ar -C -G /home/trinity/rpmbuild/RPMS.tde-${TDE_VERSION}/noarch rpmbuild.noarch

202
redhat/docker/oss153/packages

@ -0,0 +1,202 @@
alsa-devel
aspell
aspell-devel
audiofile-devel
automake
bdftopcf
bind-devel
binutils-devel
bison
brp-check-suse
brp-extract-appdata
ccache
cdparanoia
cdparanoia-devel
chmlib-devel
chrpath
clamav
clamav-devel
cln-devel
clucene-core-devel
cmake
createrepo
cups-devel
cyrus-sasl-devel
dbus-1-devel
dbus-1-glib-devel
djvulibre
docbook-utils
docbook-xsl-stylesheets
docbook2x
doxygen GraphicsMagick
dssi-devel
fdupes
ffmpeg-devel
fftw3-devel
file-devel
flac-devel
flex
freetype-devel
fribidi-devel
gamin-devel
gcc-c++
giflib-devel
git
glu-devel
gmime-devel
gmime2_6-devel
gmp-devel
gperf xmlto
GraphicsMagick-devel
gsl-devel
gstreamer-devel
gstreamer-plugins-base-devel
gstreamer-devel
gtk2-devel
gtk3-devel
gtk-doc
htdig
html2ps
hunspell-devel
iceauth
ImageMagick-devel
imlib2-devel
intltool
java-1_8_0-openjdk-devel
less
libacl-devel
libao-devel
libart_lgpl-devel
libavahi-devel
libavcodec-devel
libblkid-devel
libboost_python-py3-1_66_0-devel
libboost_system1_66_0-devel
libbz2-devel
libcap-devel
libcdio-devel
libcdio-paranoia-devel
libconfig-devel
libcryptsetup-devel
libcurl-devel
libdb-4_8-devel
libdvdread-devel
libexempi-devel
libexiv2-devel
libgadu-devel
libGeoIP-devel
libgpgme-devel
libgphoto2-devel
libgpod-devel
libgssglue-devel
libical-devel
libidn-devel
libiw-devel
libjack-devel
libjasper-devel
liblcms2-devel
liblo-devel
liblrdf-devel
libmad-devel
libmng-devel
libmp3lame-devel
libmpcdec-devel
libmtp-devel
libmusicbrainz-devel
libmysqld-devel
libneon-devel
libnjb-devel
libnsl-devel
libofx-devel
libotr-devel
libpaper-devel
libpisock-devel
libpng16-devel
libpoppler-devel
libpqxx-devel
libpulse-devel
libqalculate-devel
libraw1394-devel
librsvg-devel
libsamplerate-devel
libSDL-devel
libsmbclient-devel
libsndfile-devel
libtag-devel
libtheora-devel
libtiff-devel
libtirpc-devel
libtool
libtwolame-devel
libudev-devel
libuuid-devel
libv4l-devel
libvisual-devel
libvorbis-devel
libwmf-devel
libwpd-devel
libxine-devel
libxslt-devel
libyaz-devel
libzrtpcpp-devel
lirc-devel
make
makeinfo
meanwhile-devel
Mesa-devel
Mesa-libGL-devel
mozilla-nspr-devel
mysql-devel
net-tools
net-tools-deprecated
NetworkManager-devel
ocaml
openexr-devel
opensc
openslp-devel
opensp-devel
pam-devel
patch
pciutils-devel
pcre-devel
pcsc-lite-devel
perl-PAR-Packer
perl-pcsc
pkcs11-helper-devel
pkgconfig(pygtk-2.0)
postgresql10
postgresql10-devel
python-devel
python3-devel
python3-sip-devel
recode
rpcgen
rpm-build
rsvg-convert
ruby
ruby-devel
sane-backends-devel
scons
speex-devel
sqlite3-devel
subversion-devel
sudo
swig
sword-devel
torsocks
transfig
unixODBC-devel
update-desktop-files
usbutils
utempter-devel
valgrind
vim
wireless-tools
wv2-devel
xbase-devel
xcb-proto-devel
xorg-x11
xscreensaver
xscreensaver-data
xscreensaver-data-extra
xz-devel

4
redhat/docker/oss153/rpmmacros

@ -0,0 +1,4 @@
%dist .oss153
%_smp_mflags -j8
%jobs 8
%sle_version 150300

20
redhat/main/tdebase/tdebase.spec

@ -461,6 +461,14 @@ Requires: hicolor-icon-theme-branding
%define tde_starticon /usr/share/icons/hicolor/scalable/apps/distributor.svg
%endif
# OpenSuse 15.3 Theme
%if "%{?suse_version}" == "1530"
Requires: wallpaper-branding
%define tde_bg /usr/share/wallpapers/openSUSEdefault/contents/images/1600x1200.jpg
Requires: hicolor-icon-theme-branding
%define tde_starticon /usr/share/icons/hicolor/scalable/apps/distributor.svg
%endif
# OpenSuse TW Theme
%if "%{?suse_version}" == "1550"
Requires: wallpaper-branding
@ -1886,11 +1894,11 @@ Requires: psmisc
%if 0%{?with_hal}
Requires: hal >= 0.5
%endif
%if 0%{?rhel} == 4 || 0%{?suse_version}
Requires: cryptsetup
%else
Requires: cryptsetup-luks
%endif
#%if 0%{?rhel} == 4 || 0%{?suse_version}
#Requires: cryptsetup
#%else
#Requires: cryptsetup-luks
#%endif
Obsoletes: tdebase-kio-plugins < %{?epoch:%{epoch}:}%{version}-%{release}
Provides: tdebase-kio-plugins = %{?epoch:%{epoch}:}%{version}-%{release}
@ -2317,7 +2325,7 @@ already. Most users won't need this.
%{_sysconfdir}/init.d/xdm.tde
%endif
%if 0%{?suse_version} >= 1210
/usr/lib/X11/displaymanagers/tdm
/usr/lib/X11/displaymanagers/
%endif
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7 || 0%{?mgaversion} >= 6
/usr/lib/systemd/system/tdm.service

2
redhat/main/tdelibs/tdelibs.spec

@ -249,7 +249,7 @@ BuildRequires: iceauth
Requires: xorg-x11-server-utils
BuildRequires: xorg-x11-server-utils
%endif
%if 0%{?rhel} == 4 || 0%{?suse_version}
%if 0%{?rhel} == 4
Requires: xorg-x11
BuildRequires: xorg-x11
%endif

Loading…
Cancel
Save