You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
40 lines
1.3 KiB
40 lines
1.3 KiB
Index: tdepim/cmake/modules/TDEMacros.cmake
|
|
===================================================================
|
|
--- tdepim.orig/cmake/modules/TDEMacros.cmake
|
|
+++ tdepim/cmake/modules/TDEMacros.cmake
|
|
@@ -833,7 +833,7 @@ macro( tde_add_library _arg_target )
|
|
|
|
# set embedded archives
|
|
if( _embed )
|
|
- list( INSERT _link 0 -Wl,-whole-archive ${_embed} -Wl,-no-whole-archive )
|
|
+ list( INSERT _link 0 -Wl,-zallextract ${_embed} -Wl,-zdefaultextract )
|
|
endif( _embed )
|
|
|
|
# set link libraries
|
|
Index: tdepim/mimelib/CMakeLists.txt
|
|
===================================================================
|
|
--- tdepim.orig/mimelib/CMakeLists.txt
|
|
+++ tdepim/mimelib/CMakeLists.txt
|
|
@@ -43,7 +43,7 @@ tde_add_library( mimelib SHARED
|
|
dwstring.cpp text.cpp token.cpp uuencode.cpp
|
|
binhex.cpp
|
|
VERSION 1.0.1
|
|
- LINK ${TQT_LIBRARIES} ${TDE_LIB_DIR}/libtdefakes_pic.a
|
|
+ LINK ${TQT_LIBRARIES} ${TDE_LIB_DIR}/libtdefakes_pic.a socket nsl
|
|
DESTINATION ${LIB_INSTALL_DIR}
|
|
)
|
|
|
|
Index: tdepim/kmail/kmfoldermbox.cpp
|
|
===================================================================
|
|
--- tdepim.orig/kmail/kmfoldermbox.cpp
|
|
+++ tdepim/kmail/kmfoldermbox.cpp
|
|
@@ -46,7 +46,7 @@
|
|
#include <ctype.h>
|
|
#include <unistd.h>
|
|
|
|
-#ifdef HAVE_FCNTL_H
|
|
+#if defined(HAVE_FCNTL_H) || defined(__dilos__)
|
|
#include <fcntl.h>
|
|
#endif
|
|
|