You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
239 lines
8.3 KiB
239 lines
8.3 KiB
diff -urN debian/control.tdeab.in debian/control.tdeab.in
|
|
--- debian/control.tdeab.in 1969-12-31 18:00:00.000000000 -0600
|
|
+++ debian/control.tdeab.in 2011-08-17 15:06:12.644738668 -0500
|
|
@@ -0,0 +1,14 @@
|
|
+Package: libreofficeVER-kab-trinity
|
|
+Architecture: %OOO_BASE_ARCHS%
|
|
+Depends: libreofficeVER-core (= ${binary:Version}),
|
|
+ ${shlibs:Depends},
|
|
+ ${misc:Depends}
|
|
+Recommends: kaddressbook-trinity
|
|
+Conflicts: ure (<< 1.5.1+OOo3.1.1-15)
|
|
+Description: office productivity suite -- TDE adressbook support
|
|
+ LibreOffice is a full-featured office productivity suite that provides
|
|
+ a near drop-in replacement for Microsoft(R) Office.
|
|
+ .
|
|
+ This package allows LibreOffice to access the TDE Addressbook.
|
|
+ You need to install kaddressbook-trinity separately.
|
|
+
|
|
diff -urN debian/control.tde.in debian/control.tde.in
|
|
--- debian/control.tde.in 1969-12-31 18:00:00.000000000 -0600
|
|
+++ debian/control.tde.in 2011-08-19 16:39:45.660276026 -0500
|
|
@@ -0,0 +1,23 @@
|
|
+Package: libreofficeVER-trinity
|
|
+Architecture: %OOO_ARCHS%
|
|
+Depends: libreofficeVER-core (= ${binary:Version}),
|
|
+ ${shlibs:Depends},
|
|
+ ${misc:Depends}
|
|
+Recommends: ${tde-iconset-dep}
|
|
+Suggests: konqueror-trinity,
|
|
+ kmail-trinity,
|
|
+ libreofficeVER-kab-trinity
|
|
+Section: kde
|
|
+Enhances: libreofficeVER
|
|
+Replaces: openoffice.org-trinity (<< 1:3.3.0~)
|
|
+Description: office productivity suite -- TDE integration
|
|
+ LibreOffice is a full-featured office productivity suite that provides
|
|
+ a near drop-in replacement for Microsoft(R) Office.
|
|
+ .
|
|
+ This package contains the TDE plugin for drawing OOo's widgets with
|
|
+ TDE/TQt and a TDEish File Picker when running under TDE.
|
|
+ You can extend the functionality of this by installing these packages:
|
|
+ .
|
|
+ * konqueror-trinity / kmail-trinity
|
|
+ * libreoffice-kab-trinity: TDE Addressbook support
|
|
+
|
|
diff -urN debian/rules debian/rules
|
|
--- debian/rules 2011-04-19 17:25:22.000000000 -0500
|
|
+++ debian/rules 2011-08-19 12:24:54.642994139 -0500
|
|
@@ -175,7 +175,8 @@
|
|
BUILD_CAIROCANVAS=y
|
|
SYSTEM_STUFF += cairo
|
|
CAIRO_FONTS_PATCH=y
|
|
-BUILD_KDE=y
|
|
+BUILD_KDE=n
|
|
+BUILD_TDE=y
|
|
KDE_VER=4
|
|
ifeq "$(BUILD_KDE)" "y"
|
|
ifeq "$(KDE_VER)" "3"
|
|
@@ -191,6 +192,12 @@
|
|
QT_MINVER= (>= 4.5)
|
|
KDELIBS_MINVER= (>= 4:4.3.4)
|
|
endif
|
|
+ifeq "$(BUILD_TDE)" "y"
|
|
+ ENABLE_TDEAB=y
|
|
+endif
|
|
+ifeq "$(BUILD_TDE)" "y"
|
|
+ TDELIBS_MINVER= (>= 4:3.5.12)
|
|
+endif
|
|
BUILD_DBG_PACKAGE=y
|
|
SYSTEM_STUFF += beanshell
|
|
SYSTEM_STUFF += hsqldb
|
|
@@ -383,6 +390,7 @@
|
|
ENABLE_MYSQLNATIVE=n
|
|
ENABLE_EVO2=n
|
|
ENABLE_KDEAB=n
|
|
+ ENABLE_TDEAB=n
|
|
ENABLE_REPORTDESIGN=n
|
|
DEBHELPER_OPTIONS += -Nlibreoffice$(VER)-base libreoffice$(VER)-base-core
|
|
DEBHELPER_OPTIONS += -Nlibreoffice$(VER)-evolution -Nlibreoffice$(VER)-kab
|
|
@@ -996,6 +1004,25 @@
|
|
endif
|
|
endif
|
|
|
|
+ifeq "$(BUILD_TDE)" "n"
|
|
+ CONFIGURE_FLAGS+= --disable-tde
|
|
+ CONFIGURE_FLAGS+= --with-images="$(IMAGES)"
|
|
+else
|
|
+ CONFIGURE_FLAGS+= --disable-kde
|
|
+ CONFIGURE_FLAGS+= --disable-kde4
|
|
+ CONFIGURE_FLAGS+= --enable-tde
|
|
+ TDE_ICONSET_DEP=libreoffice$(VER)-style-crystal
|
|
+ BUILD_DEPS += , kdelibs4-trinity-dev
|
|
+
|
|
+ DBG_DBG_SUGGESTS+= , kdelibs-trinity-dbg, libtqtinterface-dbg
|
|
+
|
|
+ ifeq "$(ENABLE_TDEAB)" "y"
|
|
+ BUILD_DEPS += , kdepim-trinity-dev
|
|
+ else
|
|
+ CONFIGURE_FLAGS+= --disable-tdeab
|
|
+ endif
|
|
+endif
|
|
+
|
|
ifeq "$(ENABLE_MYSQLNATIVE)" "y"
|
|
CONFIGURE_FLAGS += --enable-mysql-connector
|
|
ifneq (,$(filter mysql, $(SYSTEM_STUFF)))
|
|
@@ -1523,6 +1550,11 @@
|
|
>> debian/control < debian/control.kde.in
|
|
perl -pi -e 's/ libreoffice$(VER)-gnome,/ libreoffice-gnome | libreoffice$(VER)-kde,/' debian/control
|
|
endif
|
|
+ifeq "$(BUILD_TDE)" "y"
|
|
+ sed -e "s|libreofficeVER|libreoffice$(VER)|g" \
|
|
+ >> debian/control < debian/control.tde.in
|
|
+ perl -pi -e 's/ libreoffice$(VER)-gnome,/ libreoffice-gnome | libreoffice$(VER)-trinity,/' debian/control
|
|
+endif
|
|
ifeq "$(ENABLE_SDBC_POSTGRESQL)" "y"
|
|
sed -e "s|libreofficeVER|libreoffice$(VER)|g" \
|
|
>> debian/control < debian/control.postgresql.in
|
|
@@ -1539,6 +1571,10 @@
|
|
sed -e "s|libreofficeVER|libreoffice$(VER)|g" \
|
|
>> debian/control < debian/control.kab.in
|
|
endif
|
|
+ifeq "$(ENABLE_TDEAB)" "y"
|
|
+ sed -e "s|libreofficeVER|libreoffice$(VER)|g" \
|
|
+ >> debian/control < debian/control.tdeab.in
|
|
+endif
|
|
endif # ifeq "$(PKGSOURCE)" "libreoffice$(VER)"
|
|
|
|
perl -pi -e "s,%OOO_ARCHS%,$(OOO_ARCHS),g" debian/control
|
|
@@ -1610,6 +1646,10 @@
|
|
perl -pi -e 's/GConf backend$$/GConf backend\n * libreoffice$(VER)-kde: KDE UI Plugin and KDE File Picker support/' debian/control
|
|
endif
|
|
|
|
+ifeq "$(BUILD_TDE)" "y"
|
|
+ perl -pi -e 's/GConf backend$$/GConf backend\n * libreoffice$(VER)-trinity: TDE UI Plugin and TDE File Picker support/' debian/control
|
|
+endif
|
|
+
|
|
ifeq "$(ENABLE_LDAP)" "y"
|
|
perl -pi -e 's/paperconf$$/paperconf\n * $(LDAP_LIB): LDAP client library; needed for LibreOffice getting its\n profiles from LDAP/' debian/control
|
|
endif
|
|
@@ -1694,6 +1734,12 @@
|
|
ln -sf /usr/bin/moc-qt$(KDE_VER) $(CURDIR)/debian/usr/bin/moc
|
|
endif
|
|
|
|
+ifeq "$(BUILD_TDE)" "y"
|
|
+ # be sure we use the right moc, FIXME: Trinity uses its own moc
|
|
+ mkdir -p $(CURDIR)/debian/usr/bin
|
|
+ ln -sf /usr/bin/moc-qt$(KDE_VER) $(CURDIR)/debian/usr/bin/moc
|
|
+endif
|
|
+
|
|
ifeq "$(USE_STLPORT)" "y"
|
|
ifeq "$(USE_SYSTEM_STLPORT)" "y"
|
|
# stlport home
|
|
@@ -1770,6 +1816,7 @@
|
|
dh_testdir
|
|
|
|
ifeq "$(BUILD_KDE)" "n"
|
|
+ ifeq "$(BUILD_TDE)" "n"
|
|
# hack to tell we want crystal icons nevertheless and they should be
|
|
# extracted...
|
|
if ! grep -q crystal $(OOO_BUILD_TREE)/bin/setup; then \
|
|
@@ -1778,6 +1825,7 @@
|
|
| sed -e s/\'industrial/\'industrial\ crystal/ \
|
|
> $(OOO_BUILD_TREE)/bin/setup && rm $(OOO_BUILD_TREE)/bin/setup.bak; \
|
|
fi
|
|
+ endif
|
|
endif
|
|
|
|
cd $(OOO_BUILD_TREE) ; \
|
|
@@ -2276,6 +2324,12 @@
|
|
-br $(PKGDIR)-core/$(OODIR)/program/services.rdb \
|
|
-c 'vnd.sun.star.expand:$$OOO_BASE_DIR/program/libkab1.so'
|
|
endif
|
|
+ifeq "$(ENABLE_TDEAB)" "y"
|
|
+ debian/ure/$(OOBRANDDIR)/ure/bin/regcomp -revoke \
|
|
+ -r $(PKGDIR)-core/$(OODIR)/program/services.rdb \
|
|
+ -br $(PKGDIR)-core/$(OODIR)/program/services.rdb \
|
|
+ -c 'vnd.sun.star.expand:$$OOO_BASE_DIR/program/libtdeab1.so'
|
|
+endif
|
|
ifeq "$(BUILD_BINFILTERS)" "y"
|
|
debian/ure/$(OOBRANDDIR)/ure/bin/regcomp -revoke \
|
|
-r $(PKGDIR)-core/$(OODIR)/program/services.rdb \
|
|
@@ -2362,6 +2416,49 @@
|
|
done
|
|
endif
|
|
|
|
+ifeq "$(BUILD_TDE)" "y"
|
|
+ mkdir -p -m755 $(PKGDIR)-trinity/$(OODIR)/program
|
|
+ mkdir -p -m755 $(PKGDIR)-trinity/$(OOBRANDDIR)/program
|
|
+ for f in fps_tde*.uno.so libvclplug_tde*.so; do \
|
|
+ mv $(PKGDIR)-core/$(OODIR)/program/$$f $(PKGDIR)-trinity/$(OODIR)/program || exit 1 ;\
|
|
+ done
|
|
+ mv $(PKGDIR)-common/$(OOBRANDDIR)/program/tdefilepicker \
|
|
+ $(PKGDIR)-trinity/$(OOBRANDDIR)/program
|
|
+
|
|
+ # install files for TDEs "create new" ...
|
|
+ mkdir -p $(PKGDIR)-trinity/usr/share/templates/.source
|
|
+ for i in $(SOURCE_TREE)/extras/source/shellnew/*; do \
|
|
+ cp $$i $(PKGDIR)-trinity/usr/share/templates/.source/`basename $$i`; \
|
|
+ done
|
|
+ cat debian/templates/soffice-template.desktop.in \
|
|
+ | sed -e "s/@APP@/Writer/" \
|
|
+ | sed -e "s/@EXT@/odt/" \
|
|
+ | sed -e "s/@TYPE@/text/" \
|
|
+ > $(PKGDIR)-trinity/usr/share/templates/soffice.odt.desktop
|
|
+ cat debian/templates/soffice-template.desktop.in \
|
|
+ | sed -e "s/@APP@/Calc/" \
|
|
+ | sed -e "s/@EXT@/ods/" \
|
|
+ | sed -e "s/@TYPE@/spreadsheet/" \
|
|
+ > $(PKGDIR)-trinity/usr/share/templates/soffice.ods.desktop
|
|
+ cat debian/templates/soffice-template.desktop.in \
|
|
+ | sed -e "s/@APP@/Impress/" \
|
|
+ | sed -e "s/@EXT@/odp/" \
|
|
+ | sed -e "s/@TYPE@/presentation/" \
|
|
+ > $(PKGDIR)-trinity/usr/share/templates/soffice.odp.desktop
|
|
+ cat debian/templates/soffice-template.desktop.in \
|
|
+ | sed -e "s/@APP@/Draw/" \
|
|
+ | sed -e "s/@EXT@/odg/" \
|
|
+ | sed -e "s/@TYPE@/drawing/" \
|
|
+ > $(PKGDIR)-trinity/usr/share/templates/soffice.odg.desktop
|
|
+endif
|
|
+ifeq "$(ENABLE_TDEAB)" "y"
|
|
+ rm -rf $(PKGDIR)-kab-trinity
|
|
+ mkdir -p -m755 $(PKGDIR)-kab-trinity/$(OODIR)/program
|
|
+ for f in libtdeab*so; do \
|
|
+ mv $(PKGDIR)-core/$(OODIR)/program/$$f $(PKGDIR)-kab-trinity/$(OODIR)/program || exit 1 ;\
|
|
+ done
|
|
+endif
|
|
+
|
|
# move the GNOME stuff which are *not* in gid_Module_Optional_Gnome
|
|
# (which is moved into -gnome in package-ooo) into -gnome
|
|
mkdir -p -m755 $(PKGDIR)-gnome/$(OODIR)/program
|
|
@@ -3455,6 +3552,7 @@
|
|
-V'ooo-binfilter-dep=$(OOO_BINFILTER_DEP)' \
|
|
-V'ooo-officebean-dep=$(OOO_OFFICEBEAN_DEP)' \
|
|
-V'kde-iconset-dep=$(KDE_ICONSET_DEP)' \
|
|
+ -V'tde-iconset-dep=$(TDE_ICONSET_DEP)' \
|
|
-V'lpsolve-dep=$(LPSOLVE_DEP)' \
|
|
-V'gstreamer-plugins-suggests=$(GSTREAMER_PLUGINS_SUGGESTS)' \
|
|
-V'libebook-dep=$(shell debian/scripts/get_libebook_dep.sh)' \
|