Add `pinentry` ebuild as TQt version.
Signed-off-by: Chris <xchrisx@uber.space>pull/70/head
parent
c164cbfdd0
commit
173015ae98
@ -0,0 +1,4 @@
|
||||
AUX pinentry-0.8.2-ncurses.patch 824 BLAKE2B 922bb9a7079d4a3bc307a441f3f884f764f78819a16b57cde3dcb000ae7a23b592b390f53c528358818087c2c313716289b829c307f07dbee3c9580bd174cd0d SHA512 415ad55fd7a4ab66e87e5db76b1314b00f5a86552804f1f431a533ba1e7ec3f2c7136096106688b572639ceb637fdf0c3e25d96aa2e07fd1f6f295d39e1d4901
|
||||
AUX pinentry-1.0.0-make-icon-work-under-Plasma-Wayland.patch 1606 BLAKE2B bebea23f44a0512dad873f693a8343a47684c983ca37faba908bee62a7f87d1eaf2a097672df45fcfabb28911b55bc3b02177f910137f50d9c97a6939a1f7047 SHA512 15e6b86015bbf9f199bfa9e68f2a1b9f3fc14105313e1dbfb303d76b1949092ec2671b8d2a90fa8b05e0196da81e9f20875656dc11fdd96b48a14d79e4becdf7
|
||||
DIST pinentry-1.1.0.tar.bz2 467702 BLAKE2B cf43555848ab0dc60756fca123aba7599ebb1bfe0458b973ed9d84479f8de9ee69ef309b518b40aa340434d64d37793cf97c94f78f99820bc5c71ecd2aac7a49 SHA512 5012672925bcb5f683358c259e55e4b87c67cf063ad52c759308933733025c33f7ce08e5b8019ffc101cbf7ef30499040ef2fd34a7611698e65e1593f80948cd
|
||||
EBUILD pinentry-1.1.0-r3.ebuild 3222 BLAKE2B bf5d1e3dd02d1c09515551dd608a26edb05b7bf3e6f5cd874f87c65871939da38823187cc7f9051b81792528bd31a99e0a6fd946723deffdd0618464b439e33d SHA512 28f02775b55f069332d0b6cd37f9265741eaed309f6cef962992697626e12a0cb330516985b7f007a7719c104dce5fa3f41716cf7466cc0db25ec123eabf24eb
|
@ -0,0 +1,25 @@
|
||||
From bafe8608fc525ef103b3d1f3048ca28958bef596 Mon Sep 17 00:00:00 2001
|
||||
From: Alon Bar-Lev <alon.barlev@gmail.com>
|
||||
Date: Sun, 5 May 2013 02:23:08 +0300
|
||||
Subject: [PATCH] ncurses: link with optional tinfo
|
||||
|
||||
---
|
||||
m4/curses.m4 | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/m4/curses.m4 b/m4/curses.m4
|
||||
index 3a01881..ffb6bd1 100644
|
||||
--- a/m4/curses.m4
|
||||
+++ b/m4/curses.m4
|
||||
@@ -36,6 +36,8 @@ AC_DEFUN([IU_LIB_NCURSES], [
|
||||
have_ncursesw=no
|
||||
fi
|
||||
if test "$LIBNCURSES"; then
|
||||
+ AC_CHECK_LIB(tinfow, curs_set, LIBNCURSES="${LIBNCURSES} -ltinfow",
|
||||
+ AC_CHECK_LIB(tinfo, curs_set, LIBNCURSES="${LIBNCURSES} -ltinfo"))
|
||||
# Use ncurses header files instead of the ordinary ones, if possible;
|
||||
# is there a better way of doing this, that avoids looking in specific
|
||||
# directories?
|
||||
--
|
||||
1.8.1.5
|
||||
|
@ -0,0 +1,52 @@
|
||||
From 7218becac7132c2508d4e8f42c693d69c406795a Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Andrius=20=C5=A0tikonas?= <andrius@stikonas.eu>
|
||||
Date: Wed, 7 Mar 2018 15:14:22 +0100
|
||||
Subject: [PATCH] Make pinentry-qt icon work under Plasma Wayland.
|
||||
|
||||
---
|
||||
qt/Makefile.am | 2 ++
|
||||
qt/main.cpp | 2 ++
|
||||
qt/org.gnupg.pinentry-qt.desktop | 5 +++++
|
||||
3 files changed, 9 insertions(+)
|
||||
create mode 100644 qt/org.gnupg.pinentry-qt.desktop
|
||||
|
||||
diff --git a/qt/Makefile.am b/qt/Makefile.am
|
||||
index 698005e..bbf39d1 100644
|
||||
--- a/qt/Makefile.am
|
||||
+++ b/qt/Makefile.am
|
||||
@@ -24,6 +24,8 @@ bin_PROGRAMS = pinentry-qt
|
||||
|
||||
EXTRA_DIST = document-encrypt.png pinentry.qrc
|
||||
|
||||
+desktopdir = $(datadir)/applications
|
||||
+dist_desktop_DATA = org.gnupg.pinentry-qt.desktop
|
||||
|
||||
if FALLBACK_CURSES
|
||||
ncurses_include = $(NCURSES_INCLUDE)
|
||||
diff --git a/qt/main.cpp b/qt/main.cpp
|
||||
index fe88d26..b767cb4 100644
|
||||
--- a/qt/main.cpp
|
||||
+++ b/qt/main.cpp
|
||||
@@ -372,6 +372,8 @@ main(int argc, char *argv[])
|
||||
i = argc;
|
||||
app = new QApplication(i, new_argv);
|
||||
app->setWindowIcon(QIcon(QLatin1String(":/document-encrypt.png")));
|
||||
+ app->setOrganizationDomain(QStringLiteral("gnupg.org"));
|
||||
+ app->setDesktopFileName(QStringLiteral("org.gnupg.pinentry-qt"));
|
||||
}
|
||||
|
||||
pinentry_parse_opts(argc, argv);
|
||||
diff --git a/qt/org.gnupg.pinentry-qt.desktop b/qt/org.gnupg.pinentry-qt.desktop
|
||||
new file mode 100644
|
||||
index 0000000..0ac89aa
|
||||
--- /dev/null
|
||||
+++ b/qt/org.gnupg.pinentry-qt.desktop
|
||||
@@ -0,0 +1,5 @@
|
||||
+[Desktop Entry]
|
||||
+Type=Application
|
||||
+Name=Pinentry dialog
|
||||
+Icon=document-encrypt
|
||||
+NoDisplay=true
|
||||
--
|
||||
2.16.1
|
||||
|
@ -0,0 +1,110 @@
|
||||
# Copyright 1999-2019 Gentoo Authors
|
||||
# Copyright 2020 The Trinity Desktop Project
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI="7"
|
||||
|
||||
inherit autotools flag-o-matic qmake-utils toolchain-funcs
|
||||
|
||||
DESCRIPTION="Simple passphrase entry dialogs which utilize the Assuan protocol"
|
||||
HOMEPAGE="https://gnupg.org/aegypten2/index.html"
|
||||
SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
|
||||
IUSE="caps emacs gnome-keyring fltk gtk ncurses qt5 tqt static"
|
||||
|
||||
DEPEND="
|
||||
app-eselect/eselect-pinentry
|
||||
>=dev-libs/libassuan-2.1
|
||||
>=dev-libs/libgcrypt-1.6.3
|
||||
>=dev-libs/libgpg-error-1.17
|
||||
caps? ( sys-libs/libcap )
|
||||
fltk? ( x11-libs/fltk )
|
||||
gnome-keyring? ( app-crypt/libsecret )
|
||||
gtk? ( x11-libs/gtk+:2 )
|
||||
ncurses? ( sys-libs/ncurses:0= )
|
||||
qt5? (
|
||||
dev-qt/qtcore:5
|
||||
dev-qt/qtgui:5
|
||||
dev-qt/qtwidgets:5
|
||||
)
|
||||
tqt? ( dev-tqt/tqt )
|
||||
static? ( >=sys-libs/ncurses-5.7-r5:0=[static-libs,-gpm] )
|
||||
"
|
||||
RDEPEND="${DEPEND}
|
||||
gnome-keyring? ( app-crypt/gcr )
|
||||
"
|
||||
BDEPEND="
|
||||
sys-devel/gettext
|
||||
virtual/pkgconfig
|
||||
"
|
||||
|
||||
REQUIRED_USE="
|
||||
gtk? ( !static )
|
||||
qt5? ( !static )
|
||||
tqt? ( !static )
|
||||
"
|
||||
|
||||
DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/${PN}-1.0.0-make-icon-work-under-Plasma-Wayland.patch"
|
||||
"${FILESDIR}/${PN}-0.8.2-ncurses.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
eautoreconf
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
use static && append-ldflags -static
|
||||
[[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11
|
||||
|
||||
export QTLIB="$(qt5_get_libdir)"
|
||||
|
||||
econf \
|
||||
$(use_enable emacs pinentry-emacs) \
|
||||
$(use_enable fltk pinentry-fltk) \
|
||||
$(use_enable gnome-keyring libsecret) \
|
||||
$(use_enable gnome-keyring pinentry-gnome3) \
|
||||
$(use_enable gtk pinentry-gtk2) \
|
||||
$(use_enable ncurses fallback-curses) \
|
||||
$(use_enable ncurses pinentry-curses) \
|
||||
$(use_enable qt5 pinentry-qt) \
|
||||
$(use_enable tqt pinentry-tqt) \
|
||||
$(use_with caps libcap) \
|
||||
--enable-pinentry-tty \
|
||||
FLTK_CONFIG="${EROOT}/usr/bin/fltk-config" \
|
||||
MOC="$(qt5_get_bindir)"/moc \
|
||||
GPG_ERROR_CONFIG="${EROOT}/usr/bin/${CHOST}-gpg-error-config" \
|
||||
LIBASSUAN_CONFIG="${EROOT}/usr/bin/libassuan-config" \
|
||||
$("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
|
||||
}
|
||||
|
||||
src_install() {
|
||||
default
|
||||
rm -f "${ED}"/usr/bin/pinentry
|
||||
|
||||
use qt5 && dosym pinentry-qt /usr/bin/pinentry-qt4
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
if ! has_version 'app-crypt/pinentry' || has_version '<app-crypt/pinentry-0.7.3'; then
|
||||
elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
|
||||
elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
|
||||
elog "The soft resource limit for memory locking specifies the limit an"
|
||||
elog "unprivileged process may lock into memory. You can also use POSIX"
|
||||
elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
|
||||
elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
|
||||
elog "your users."
|
||||
fi
|
||||
|
||||
eselect pinentry update ifunset
|
||||
}
|
||||
|
||||
pkg_postrm() {
|
||||
eselect pinentry update ifunset
|
||||
}
|
@ -0,0 +1,2 @@
|
||||
AUX pinentry.eselect-0.7 419 BLAKE2B 0628d715d942f55124545fcef1060cbae4629039902f920358d5e56433dc682b5ed313d3537814f8c134d9ac96fc59f9811179c6793339ee7f67eb907cb1def0 SHA512 07f3e6acaa9e2451f5978b5ef1b509e86d962f4b792339503c6f232566f7f22ecd6842f4828384366a3e6f0259bf899988678667366b321074c235ce6e2338e3
|
||||
EBUILD eselect-pinentry-0.7.ebuild 690 BLAKE2B efa5f15c50e8cd136e7988ccd78dc8fe9e29b20912816002f9a1fe2e19f9c59bda9774eb6d914ebcffbea5bce44a315fd4381e6cf02b0484c96c0e4bc4c1a3b4 SHA512 ba1107a5113bd3bd51b647d01ffe327915d5c0472b049e9602f8022bf0a3d33c113a2b16fc11ac626942272326b39936507f20710c28f2341e39f1612b0f2783
|
@ -0,0 +1,22 @@
|
||||
# Copyright 1999-2020 Gentoo Authors
|
||||
# Copyright 2020 The Trinity Desktop Project
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI="7"
|
||||
|
||||
DESCRIPTION="Manage /usr/bin/pinentry symlink"
|
||||
HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~riscv s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
|
||||
|
||||
RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
|
||||
|
||||
S="${FILESDIR}"
|
||||
|
||||
src_install() {
|
||||
default
|
||||
insinto /usr/share/eselect/modules
|
||||
newins pinentry.eselect-${PV} pinentry.eselect
|
||||
}
|
@ -0,0 +1,12 @@
|
||||
# Copyright 1999-2016 Gentoo Foundation
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
DESCRIPTION="Manage /usr/bin/pinentry implementation"
|
||||
MAINTAINER="ssuominen@gentoo.org"
|
||||
VERSION="0.7"
|
||||
|
||||
SYMLINK_PATH=/usr/bin/pinentry
|
||||
SYMLINK_TARGETS=( pinentry-gnome3 pinentry-qt pinentry-tqt pinentry-gtk-2 pinentry-qt4 pinentry-curses pinentry-tty )
|
||||
SYMLINK_DESCRIPTION='pinentry binary'
|
||||
|
||||
inherit bin-symlink
|
Loading…
Reference in New Issue