Signed-off-by: ormorph <roma251078@mail.ru>
(cherry picked from commit 09c45f2ef3
)
r14.1.x
parent
594492c4f8
commit
532048b6ed
@ -0,0 +1 @@
|
||||
DIST compiz-0.9.14.2.tar.xz 3928596 BLAKE2B aabb6b9a58deec68ec13eef6a8adf47b139a800da66822a4845b3bf55f7ea6f04ce8c96e690e2380af58226cb74e7a0404e6217a0189a86fe19953274fb63b5a SHA512 6d064c65be2af5a9676021d35ade64d262f1ddff0e974bd711805b6975d99697bb188f4a13d919b6f0f26a49544305d397d6c74e790b7672caeffc38f74ab145
|
@ -0,0 +1,147 @@
|
||||
# Copyright 1999-2023 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
PYTHON_COMPAT=( python3_{8..12} )
|
||||
BRANCH="0.9.14"
|
||||
|
||||
inherit cmake xdg-utils python-single-r1 toolchain-funcs
|
||||
|
||||
if [[ ${PV} == 9999* ]]; then
|
||||
inherit git-r3
|
||||
EGIT_REPO_URI="https://git.launchpad.net/${PN}"
|
||||
S="${WORKDIR}/${P}"
|
||||
else
|
||||
SRC_URI="http://launchpad.net/${PN}/${BRANCH}/${PV}/+download/${P}.tar.xz"
|
||||
KEYWORDS="~amd64"
|
||||
fi
|
||||
|
||||
DESCRIPTION="OpenGL window and compositing manager"
|
||||
HOMEPAGE="https://launchpad.net/compiz"
|
||||
|
||||
LICENSE="GPL-2 LGPL-2.1 MIT"
|
||||
SLOT="0"
|
||||
|
||||
IUSE="+cairo debug dbus gles gnome gtk kde +svg test"
|
||||
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
|
||||
RESTRICT="!test? ( test )"
|
||||
|
||||
COMMONDEPEND="
|
||||
${PYTHON_DEPS}
|
||||
dev-libs/boost
|
||||
dev-libs/glib:2
|
||||
dev-cpp/glibmm:2
|
||||
dev-libs/libxml2
|
||||
dev-libs/libxslt
|
||||
$(python_gen_cond_dep '
|
||||
dev-python/cython[${PYTHON_USEDEP}]
|
||||
dev-python/setuptools[${PYTHON_USEDEP}]
|
||||
')
|
||||
dev-libs/protobuf
|
||||
media-libs/libpng
|
||||
x11-base/xorg-server
|
||||
x11-libs/libX11
|
||||
x11-libs/libXcomposite
|
||||
x11-libs/libXcursor
|
||||
x11-libs/libXdamage
|
||||
x11-libs/libXext
|
||||
x11-libs/libXrandr
|
||||
x11-libs/libXrender
|
||||
x11-libs/libXinerama
|
||||
x11-libs/libICE
|
||||
x11-libs/libSM
|
||||
x11-libs/startup-notification
|
||||
virtual/opengl
|
||||
virtual/glu
|
||||
cairo? ( x11-libs/cairo[X] )
|
||||
gtk? (
|
||||
x11-libs/gtk+:3
|
||||
x11-libs/libwnck:3
|
||||
x11-libs/pango
|
||||
gnome? (
|
||||
gnome-base/gnome-desktop:=
|
||||
x11-wm/metacity
|
||||
)
|
||||
)
|
||||
kde? ( kde-plasma/kwin )
|
||||
svg? (
|
||||
gnome-base/librsvg:2
|
||||
x11-libs/cairo
|
||||
)
|
||||
dbus? ( sys-apps/dbus )"
|
||||
|
||||
DEPEND="${COMMONDEPEND}
|
||||
app-admin/chrpath
|
||||
virtual/pkgconfig
|
||||
test? (
|
||||
dev-cpp/gtest
|
||||
)"
|
||||
|
||||
RDEPEND="${COMMONDEPEND}
|
||||
x11-apps/mesa-progs
|
||||
x11-apps/xvinfo
|
||||
x11-themes/hicolor-icon-theme"
|
||||
PATCHES=(
|
||||
"${FILESDIR}/access_violation.patch"
|
||||
"${FILESDIR}/gtk-extents.patch"
|
||||
)
|
||||
|
||||
pkg_pretend() {
|
||||
if [[ ${MERGE_TYPE} != binary ]]; then
|
||||
[[ $(gcc-major-version) -lt 4 ]] || \
|
||||
( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
|
||||
&& die "Sorry, but gcc 4.6 or higher is required."
|
||||
fi
|
||||
}
|
||||
|
||||
pkg_setup() {
|
||||
python-single-r1_pkg_setup
|
||||
}
|
||||
|
||||
src_prepare() {
|
||||
cmake_src_prepare
|
||||
sed -i \
|
||||
-e 's|CYTHON_BIN cython3|CYTHON_BIN cython|' \
|
||||
compizconfig/compizconfig-python/CMakeLists.txt || die
|
||||
eapply_user
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
use debug && CMAKE_BUILD_TYPE=Debug
|
||||
local mycmakeargs=(
|
||||
-DUSE_GLES=$(usex gles)
|
||||
-DUSE_GNOME=$(usex gnome)
|
||||
-DUSE_METACITY=$(usex gnome)
|
||||
-DUSE_GTK=$(usex gtk)
|
||||
-DCMAKE_CXX_STANDARD=17
|
||||
-DCMAKE_BUILD_TYPE=Release
|
||||
-DCOMPIZ_BUILD_TESTING=$(usex test)
|
||||
-DCOMPIZ_DEFAULT_PLUGINS=composite,opengl,decor,resize,place,move,ccp
|
||||
-DCOMPIZ_DISABLE_SCHEMAS_INSTALL=On
|
||||
-DCOMPIZ_PACKAGING_ENABLED=On
|
||||
-DCOMPIZ_BUILD_WITH_RPATH=Off
|
||||
-DCOMPIZ_WERROR=Off
|
||||
-Wno-dev
|
||||
)
|
||||
cmake_src_configure
|
||||
}
|
||||
|
||||
src_install() {
|
||||
cmake_src_install
|
||||
python_fix_shebang "${ED}"
|
||||
python_optimize
|
||||
}
|
||||
|
||||
pkg_postinst() {
|
||||
xdg_desktop_database_update
|
||||
xdg_icon_cache_update
|
||||
if use dbus; then
|
||||
ewarn "The dbus plugin is known to crash compiz in this version. Disable"
|
||||
ewarn "it if you experience crashes when plugins are enabled/disabled."
|
||||
fi
|
||||
}
|
||||
|
||||
pkg_postrm() {
|
||||
xdg_desktop_database_update
|
||||
xdg_icon_cache_update
|
||||
}
|
@ -0,0 +1,18 @@
|
||||
--- compiz-9999/compizconfig/libcompizconfig/config/CMakeLists.txt.orig 2015-02-03 12:09:12.000000000 +0100
|
||||
+++ compiz-9999/compizconfig/libcompizconfig/config/CMakeLists.txt 2015-06-14 13:12:15.009100624 +0200
|
||||
@@ -4,4 +4,4 @@
|
||||
configure_file (${CMAKE_CURRENT_SOURCE_DIR}/config_test
|
||||
${CMAKE_CURRENT_BINARY_DIR}/compiz-1/compizconfig/config)
|
||||
|
||||
-install (FILES ${_config_file} DESTINATION ${COMPIZCONFIG_CONFIG_DIR})
|
||||
+install (FILES ${_config_file} DESTINATION $ENV{DESTDIR}${COMPIZCONFIG_CONFIG_DIR})
|
||||
--- compiz-9999/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake.orig 2016-08-01 22:56:04.317994940 +0200
|
||||
+++ compiz-9999/cmake/recompile_gsettings_schemas_in_dir_user_env.cmake 2016-08-01 22:58:03.707528553 +0200
|
||||
@@ -18,6 +18,6 @@
|
||||
if (GLIB_COMPILE_SCHEMAS)
|
||||
|
||||
message ("-- Recompiling GSettings schemas in ${SCHEMADIR}")
|
||||
- execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} ${SCHEMADIR})
|
||||
+ execute_process (COMMAND ${GLIB_COMPILE_SCHEMAS} \"$ENV{DESTDIR}${SCHEMADIR}\")
|
||||
|
||||
endif (GLIB_COMPILE_SCHEMAS)
|
@ -0,0 +1,13 @@
|
||||
# Diff from https://code.launchpad.net/~albertsmuktupavels/compiz/add-gtk-frame-extents-to-net-supported/+merge/257303
|
||||
=== modified file 'src/screen.cpp'
|
||||
--- a/src/screen.cpp 2014-12-02 19:37:10 +0000
|
||||
+++ b/src/screen.cpp 2015-04-23 20:41:24 +0000
|
||||
@@ -2362,6 +2362,7 @@
|
||||
|
||||
atoms.push_back (Atoms::wmUserTime);
|
||||
atoms.push_back (Atoms::frameExtents);
|
||||
+ atoms.push_back (Atoms::frameGtkExtents);
|
||||
atoms.push_back (Atoms::frameWindow);
|
||||
|
||||
atoms.push_back (Atoms::winState);
|
||||
|
@ -0,0 +1,8 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
|
||||
<pkgmetadata>
|
||||
<maintainer type="project">
|
||||
<email>team-gentoo@trinitydesktop.org</email>
|
||||
<name>Trinity Gentoo ebuilds project</name>
|
||||
</maintainer>
|
||||
</pkgmetadata>
|
Loading…
Reference in new issue